Msg: Check Limits

How do I check Limits in LaserGRBL v4.4.1?
I keep getting Homing fail and then [Msg: check limits]

My LaserMaster2 is not working correctly nor is my Universal Engraver.


Generally the checking of your endstops is a function of your firmware and you only use your desktop computer to enter commands into a console interface. Have you searched google for your controller name( GRBL, smoothie, Marlin, etc ) along with “testing endstop switches”?

Are you powering up your LM2 and see stepper motor movement? Power sequence should be:
USB and power disconnected
connect LM2 power supply
turn on LM2( push and hold for a couple or 3 seconds the power button and see the light go on)
plug in the USB cable to the LM2 and then the computer
Connect your software to the USB port

yes I have done these steps multiple times. I do not always get the check limits message now.
But my home button continues to change where my laser head ends up. What I have always called home is at the limit switch is located at the lower left side right behind the motherboard.

My x and y axis used to always show 0 at this location. Now it shows -15 for both.
Is there somewhere that shows what the GRBL configuration default settings should be for the LaserMaster2 15w 400x430?

It seems my google skills keep bringing up the same videos that have yet to tell me anything that helps.

Thanks in advance.

Does it automatically go to the home switches when you power it on? It should be a gentle click when it touches the switch and then backs off just a mm or 2. It should not hit the limit switch and then you hear the motor still trying to move the laser head into the switch.

Also, so you have not found anything on M119 command? That should have shown up a bunch of times and they should tell you how to use that command to test your switches.

But the very first thing you should be looking at is your belt tension for both X and Y axis and make sure they are properly tensioned.